
官方文档描述的不是很清楚,
https://docs-pd.mingdao.com/deployment/proxy/file_multipleurl
我在想是不是这样填:
ENV_FILE_DOMAIN: "http://192.168.0.119:8881" # 新增变量,指定文件独立地址
ENV_FILE_ADDRESS_MAIN: "http://192.168.0.119:8881" # 新增变量,指定文件独立地址
ENV_HAP_INTRANET_FILE_ENDPOINT: "app:8880/file" # 新增变量,固定值
有没有配置过的老哥给点指导 🎉️
好
是因为文件扩展地址,对应的 nginx 的上传文件大小限制没有配置,现在好了,一切正常~~~
好,那下次再看,估计哪里细节没处理对
来不及了,现在要去接孩子放学了 😕 。我晚点回去先看下 nginx 日志,然后手机抓一下数据包看看。
你等会儿 15:40 方便吗?我发个会议号一起看下
非常感谢您的回复,目前已跑通独立文件地址部署。
![608b55c2f3483c75df0c412ac994d469.jpg]()
本地走局域网 ip、外部走域名(nginx pdaddr 转发),都已经成功。
可是,在实际使用中,发现:上传图片的时候会出现异常。
![0a182d4d32d338a11b907347f76d7758.png]()
异常一:表单中 原生组件、拍照上传附件,失败!!!
异常二:扫码拍照上传附件,失败!!!
![044a48247638f422b6c44b16d64227ed.jpg]()
但是添加本地图片,倒是 ok 的!!
![0ee061236e7e6712c2a3d8cbe6515342.png]()
目前测试的是域名访问,局域网我还没测试过,等我晚点测试一下。
谢谢,我试试~
ENV_FILE_DOMAIN: "http://192.168.0.119:8881" # 新增变量,指定文件独立地址
ENV_FILE_ADDRESS_MAIN: "http://192.168.0.119:8881" # 新增变量,指定文件独立地址
ENV_HAP_INTRANET_FILE_ENDPOINT: "app:8880/file" # 新增变量,固定值
upstream file {
server
192.168.0.119:9000; # 指定后端微服务的 IP 及映射到微服务宿主机上的文件存储端口}
server {
listen 8881;
server_name 192.168.0.119; # 指定文件独立地址
access_log /data/logs/weblogs/file.domain.com.log main; # 日志路径,可自定义
error_log /data/logs/weblogs/file.domain.com.error.log; # 日志路径,可自定义
}