根据文档里面这个扩展代码块执行环境版本,拓展后代码块依赖库是两个版本互相独立的还是共用的吗?

问答  收藏
10 / 183

https://docs.pd.mingdao.com/faq/codeextensionversion
根据文档里面这个扩展代码块执行环境版本,拓展后代码块依赖库是两个版本互相独立的还是共用的吗?

我之前 3.6 版本,pymysql 库用的好好的,突然最近就是报错了。

/usr/local/lib/python3.6/site-packages/pymysql/_auth.py:8: CryptographyDeprecationWarning: Python 3.6 is no longer supported by the Python core team. Therefore, support for it is deprecated in cryptography. The next release of cryptography will remove support for Python 3.6. from cryptography.hazmat.backends import default_backend

GPT 说:这个告警的意思是,你正在使用的 Python 版本(Python 3.6)已经不再得到 Python 核心团队的支持。因此,cryptography 库对 Python 3.6 的支持已经被弃用。

然后我升级了环境版本,切换到 3.12 版本后又报错:好像说我没有这个 pymysql 库
Traceback (most recent call last): File "//.api.py", line 49, in output = api() ^^^^^ File "//.api.py", line 7, in API import pymysqlModuleNotFoundError: No module named 'pymysql'

求大佬解答