又要麻烦吴老师了,在部署的时候提示错误Service response code error 马先生1Lv.5明道 发布于 2024-04-12 11:35 最后回复 2024-04-12 16:13:41 私有部署 收藏 复制链接 新浪微博 微信扫一扫 分享 6 回复1360 浏览 The complete service startup is expected to take 5 minutes, please do not access the service during startup! [###################################################][100%][|] Service response code error
看着头晕啊
GET 继续测试
https://docs-pd.mingdao.com/faq/deployment#%E5%88%9D%E5%A7%8B%E5%8C%96%E5%AE%8C%E6%88%90%E5%90%8E%E6%8F%90%E7%A4%BA%E8%B4%A6%E5%8F%B7%E5%B7%B2%E9%80%80%E5%87%BA%E8%AF%B7%E9%87%8D%E6%96%B0%E7%99%BB%E5%BD%95
ENV_ROLE_MODE_WAITMS变量值 调大一点,比如 3 分钟 5 分钟。重启后等待 5 分钟 + 上面的变量值时间(例如 3 分钟),总共等待 8 分钟后再访问
继续求支持
![image.png]()
不稳定 ,有时候正常返回
有的时候 curl: (56) Recv failure: Connection reset by peer
curl 127.0.0.1:8880 看下有没有返回页面,有基本就正常了。
启动后 5 分钟有一个 curl 的检查,如果状态码不是 200,就会提示这个。两种可能,一种是服务容器都没启动,或者启动失败了。另外一种就是服务器性能太低,比如磁盘,导致进程启动较慢,5 分钟后才启动完成。
通常页面可以访问,并且微服务容器日志没有错误就可以。
docker logs $(docker ps | grep community | awk '{print $1}') 可以参考微服务容器日志。