由于周末服务器需要断电,故用 shutdown 命令关闭了服务器。服务器设置了上电自动恢复,今天早上发现明道云服务启动失败,重启多次后也无法恢复。
有没有熟悉以下错误的朋友,帮忙看下如何解决。
错误日志
Removing script_app_1 ... done
Removing script_doc_1 ... error
ERROR: for script_doc_1 container a7ad6f5cfe6ac8daf6c6277fc0f4283b04e521cd60ab893e0ec712e9712a6720: driver "overlay2" failed to remove root filesystem: readdirnames /var/lib/docker/overlay2/7d14dde7740ba2aae517bfd4f5fa7f2585ce116d9990356f235e50caa9a4ce68/diff/usr/lib/erlang/bin: readdirent bin: structure needs cleaning
回晚了... 单机版本默认 MongoDB 未开启认证,也未映射出端口 外部无法访问。没有单独配置过添加认证就不用再手动建库。
刚好专家在,想要问一下升级 4.0.0 时,有个问题:这个操作具体怎么做?
👍
问题解决了,解决步骤:
另外,为什么是强制?
正常情况下 docker image rm 普通删除镜像就可以,是有什么问题吗
是不是不正常关机导致文件系统出现一些异常?https://blog.csdn.net/weixin_37549838/article/details/114365965
系统中使用其他命令,访问文件等正常吗?
👀️ 大单哦
吴工:
我强制删除了这个镜像,然后又重新 pull 新的镜像,问题照旧。
我试了一下,报错了
docker image rm registry.cn-hangzhou.aliyuncs.com/mdpublic/mingdaoyun-doc:1.2.0
Error response from daemon: conflict: unable to remove repository reference "registry.cn-hangzhou.aliyuncs.com/mdpublic/mingdaoyun-doc:1.2.0" (must force) - container 63eaea8072b1 is using its referenced image e00b69c65b4f
删除过 service.pid,重启后还是失败,依然是 doc 服务启动失败。
我搜索了下网络,structure needs cleaning,这个错误是磁盘错误带来的。有没有办法可以重新 mount。
删掉 doc 这个镜像, 重新下载后再启动看看
这两个步骤都操作下:
服务器重启后,明道云服务无法正常启动
服务器重启后,明道云服务无法正常启动