服务器:CentOS7 (最小化安装)
docker 离线安装,能正常使用

管理器能正常访问,自检没问题,但是在初始化的时候就报错了


报错信息如下:
`Y,User,root
Y,Selinux,Permissive
Y,Firewalld,not running
Y,CPU,4
Y,Memory,20
Y,docker,executable
Y,dockerd,executable
Y,MaxMapCount,65530
Y,SysFileNr,2056577
Y,IPv4Forward,1
Y,DockerCgroupDrive,cgroupfs
Y,DockerdFileNr,1048576
Y,Umask,0022
API 模式启动 ServerId 服务
已加载镜像: registry.cn-hangzhou.aliyuncs.com/mdpublic/mingdaoyun-community:4.1.1
已加载镜像: registry.cn-hangzhou.aliyuncs.com/mdpublic/mingdaoyun-doc:1.2.0
Creating network "script_default" with the default driver
Failed to Setup IP tables: Unable to enable SKIP DNAT rule: (iptables failed: iptables --wait -t nat -I DOCKER -i br-d1c22dcd75a8 -j RETURN: iptables: No chain/target/match by that name.
(exit status 1))
完整启动服务预计需要等待 5 分钟,启动期间请勿访问服务!
./service.sh:行 135: wget: 未找到命令
CommunityVersion: 4.1.1
Name: localhost.localdomain
ExternalIP:
InternalIP: 192.168.1.166
CPU(Core): 4
Mem(GB): 20.53
Disk: /dev/mapper/centos-root 47G 24G 24G 51% / /dev/sda1 1014M 151M 864M 15% /boot
Kernel: Linux localhost.localdomain 3.10.0-1160.el7.x86_64 #1 SMP Mon Oct 19 16:18:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
check:
Y,User,root
Y,Selinux,Permissive
Y,Firewalld,not running
Y,CPU,4
Y,Memory,20
Y,docker,executable
Y,dockerd,executable
Y,MaxMapCount,262144
Y,SysFileNr,2056577
Y,IPv4Forward,1
Y,DockerCgroupDrive,cgroupfs
Y,DockerdFileNr,1048576
Y,Umask,0022
installer:
root 1939 0.0 0.1 572440 28672 pts/0 Sl 21:37 0:00 ./bin/amd64/mingdaoyun_private_deployment_captain --path /data/mingdao --port 38880
root 5277 0.0 0.0 112824 968 pts/0 S 21:42 0:00 grep mingdaoyun_private_deployment_captain
root 1933 0.0 0.0 113412 1588 pts/0 S 21:37 0:00 /bin/bash ./service.sh startServerIdExec
root 1983 0.3 0.0 113548 1816 pts/0 S 21:37 0:01 /bin/bash ./service.sh startall
root 5279 0.0 0.0 112824 968 pts/0 S 21:42 0:00 grep service.sh
-rw-r--r--. 1 root root 172 5 月 24 21:37 /data/mingdao/data
service config:
version: '3'
services:
app:
image: registry.cn-hangzhou.aliyuncs.com/mdpublic/mingdaoyun-community:4.1.1
environment:
ENV_ADDRESS_MAIN: "MASKMASKMASK"
ENV_APP_VERSION: "MASKMASKMASK"
ENV_API_TOKEN: "MASKMASKMASK"
ports:
- 8880:8880
volumes:
- ./volume/data/:/data/
- ../data:/data/mingdao/data
- /usr/share/zoneinfo/Etc/GMT-8:/etc/localtime
doc:
image: registry.cn-hangzhou.aliyuncs.com/mdpublic/mingdaoyun-doc:1.2.0
docker containers:
docker images:
registry.cn-hangzhou.aliyuncs.com/mdpublic/mingdaoyun-community 4.1.1 4155f0ae3a51 37 hours ago 9.17GB
registry.cn-hangzhou.aliyuncs.com/mdpublic/mingdaoyun-file 1.4.0 dc5b955d9cd1 9 days ago 4.12GB
registry.cn-hangzhou.aliyuncs.com/mdpublic/mingdaoyun-doc 1.2.0 cc4d668f289b 2 months ago 2.66GB
"docker logs" requires exactly 1 argument.
See 'docker logs --help'.
Usage: docker logs [OPTIONS] CONTAINER
Fetch the logs of a container
服务响应码错误 `
好嘞,谢谢大哥
申请密钥页面,有一个登录并申请密钥按钮,点击会有调整的 URL 地址,内网无法访问此地址的话,将地址搞到能访问外网的电脑上,通过这个地址访问进行申请社区版密钥了。验证不需要联网
谢谢大哥,按照指引重新安装成功了。想问一下,如果内网服务器没有互联网权限,是不是找一个 pc 先去申请秘钥,然后再回来注册验证?但是验证需要联网吗?
原因是关闭防火墙时会清空 iptables 规则,所以需要重启 Docker 重新生成 Docker 默认的 iptables 规则,解决问题后 [重新安装] 即可(https://docs.pd.mingdao.com/faq/deployment/#%E5%A6%82%E4%BD%95%E9%87%8D%E6%96%B0%E5%AE%89%E8%A3%85)。
收到,我试试
./service.sh:行 135: wget: 未找到命令
![image.png]()
我看了一下 service.sh 第 135 行,应该是访问明道云绑定 ip+mac,如果是纯内网(没有互联网),那是不是不能用?
重启一下 docker,然后再重新安装,重新安装步骤可参考:
部署问题 | 明道云私有部署 (mingdao.com)