【已解决】私有部署,升级3.5 调整数据库后,重启服务器,Nginx报502 bad getway CHAOHUANGLv.5明道 发布于 2022-10-07 13:21 最后回复 2022-10-12 11:27:05 分享 明道云私有部署更新 收藏 复制链接 新浪微博 微信扫一扫 分享 7 回复1509 浏览 重启服务后,Nginx 报 502 badget way, Nginx 版本 1.20.1, 检查 nginx 状态是启用的, 重启 nginx 后,依然显示 502 nginx bad getway。 之前进行了 3.4 版本要求的数据库调整。 求帮助。
3.5.1 已经发布了,问题已解决 升级下
![image.png]()
没有测,不清楚呢
没有出现批量打印报错吗?
哈哈哈,一样的~ 我的服务器也是每天备份。 然后出了问题就回滚。
解决了:
问题是之前定位错误出现了偏差。 一直以为 502 错误是 nginx 的问题, 其实是因为明道微服务的启动异常造成的。
通常我一般是直接 在 mingdao 目录下 bash ./service.sh restartall. 报错期间, 执行该命令会发现 执行结果在 stop 和 start 中间多了一个 error。
这说明我们的微服务启动是有异常的。
这里应该先在该目录下执行
bash ./service.sh stopall,停止所有服务。然后先 删除原有到的 service 服务,rm -f service.pid,再执行bash ./service.sh startall`,等待命令执行完成即可。如果不出意外,这样微服务应该就正常启动了。如果出了意外,那就当我没说。
服务启动后,检查下 nginx 状态,如果没有启动,就启动 Nginx。这里我的问题就解决了。
我前两天升级了 3.5,是这个问题 私有部署 3.5.0 批量打印报错,如下
然后火速回滚了,幸好升级前做了快照
重启服务器之前还做了 swap 虚拟内存的设置。