用虚拟机部署,提示初始化失败。 赵星Lv.1问道 发布于 2022-08-15 12:10 最后回复 2022-08-16 17:55:47 私有部署 收藏 复制链接 新浪微博 微信扫一扫 分享 5 回复1247 浏览 虚拟机分的配置是 12 vcpu 24 g 内存 按道理是够最低配置了。 虚拟机分的配置是 12 vcpu 24 g 内存 按道理是够最低配置了。
https://shimo.im/docs/WlArzzY5EZtvvJA2/ 《离线安装 Docker-20.10.16》,可复制链接后用石墨文档 App 或小程序打开
部署前服务器需要(一步不能漏)
关闭防火墙 systemctl stop firewalld
关闭防火墙开机启动 systemctl disable firewalld
关闭 selinux,命令 setenforce 0
永久关闭 selinux,命令 sed -i 's/enforcing/disabled/g' /etc/selinux/config
然后再按照如下链接安装 docker
ERROR: for script_app_1 Cannot start service app: mounting shm tmpfs: invalid argument
ERROR: for doc Cannot start service doc: mounting shm tmpfs: invalid argument
ERROR: for app Cannot start service app: mounting shm tmpfs: invalid argument
selinux 状态检测下,设置为 永久禁用
[root@anonymous ]# cat /data/mingdao/script/mingdaoyun.log
Creating network "script_default" with the default driver
Creating script_doc_1 ... done
Creating script_app_1 ... done